Problems connecting to Nexus365?

Older versions of TLS will no longer connect to Nexus365 after October 2018

Microsoft have announced that from the end of October 2018 they will only accept TLS 1.2 connections – support for older versions of TLS will no longer be accepted.

In order to connect securely to Nexus365 you will need a modern web browser or client software which use TLS 1.2 or later.

Known software which does not support TLS 1.2:

  • Android 4.3 (and earlier)
  • Firefox version 5.0 (and earlier – and any related forks of it)
  • Internet Explorer 8-10 on Windows 7 (and earlier)
  • Internet Explorer 10 on Windows Phone 8.0
  • Safari 6.0.4/OS X10.8.4 (and earlier)

If you are running any of the software versions above then you should look to update them to the latest versions.

More information can be found about this on the IT Services blog: http://blogs.it.ox.ac.uk/nexus/2018/07/26/tls/